PHP Classes

For sure because is outdated this package really need love bu...

Recommend this page to a friend!

      Bounce Handler  >  All threads  >  For sure because is outdated this...  >  (Un) Subscribe thread alerts  
Subject:For sure because is outdated this...
Summary:Package rating comment
Messages:5
Author:Jean-Christophe
Date:2014-10-22 07:00:00
 

Jean-Christophe rated this package as follows:

Utility: Good
Consistency: Sufficient
Examples: Sufficient

  1. For sure because is outdated this...   Reply   Report abuse  
Picture of Jean-Christophe Jean-Christophe - 2014-10-22 07:00:00
For sure because is outdated this package really need love but because is the only and REALLY the only one complete class for parsing bounce receive I freaking love this package.

Soon I install this in my system I'll branch it's debugged version here!

  2. Re: For sure because is outdated this...   Reply   Report abuse  
Picture of Chris Fortune Chris Fortune - 2014-10-22 16:47:33 - In reply to message 1 from Jean-Christophe
Hey, thanks Jean-Christophe! It's been in development a few years now and it's in production at some major email providers.

There's a new version being built on github at https://github.com/cfortune/PHP-Bounce-Handler . Please feel free to join in the dev there, you can always fork from the latest Master branch, make any changes, and then issue a "pull request" so I can merge your changes.

Once that version is stable (probably 7.6), I'll post a copy of it here.

Some day I would like to do a full OOP rewrite, using the Chain of Responsibility pattern. This would allow separation of RFC parsing, FBL parsing, Exim parsing, Postfix parsing, etc....

  3. Re: For sure because is outdated this...   Reply   Report abuse  
Picture of Jean-Christophe Jean-Christophe - 2014-10-22 17:02:45 - In reply to message 2 from Chris Fortune
Wow! I am so glad to hear you here at the PHPclass.org!
Is nice that you provided an github built!

I follow right now your built.

  4. Re: For sure because is outdated this...   Reply   Report abuse  
Picture of Manuel Lemos Manuel Lemos - 2014-10-24 10:30:01 - In reply to message 2 from Chris Fortune
Nowadays you can import the update package files easily from a Git repository.

phpclasses.org/blog/post/164-Tutori ...

The site also imports the package updates from the repository automatically, so you do not have to do it all the time manually.

phpclasses.org/blog/post/233-Automa ...

  5. Re: For sure because is outdated this...   Reply   Report abuse  
Picture of Jean-Christophe Jean-Christophe - 2014-10-24 17:50:03 - In reply to message 4 from Manuel Lemos
Yes! The exact information I wanted to post!
Tank you so mush! Manuel!

 
For more information send a message to info at phpclasses dot org.